# CVE-2024-29194: OneUptime Vulnerable to a Privilege Escalation via Local Storage Key Manipulation

> Attackers can gain administrative privileges by manipulating the is_master_admin key in browser local storage due to missing server-side validation.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Mar 2024
- **Updated:** 13 Aug 2024
- **Also known as:** GHSA-246p-xmg8-wmcq

## What is CVE-2024-29194?

CVE-2024-29194 is a high-severity vulnerability in oneuptime, published on 24 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OneUptime is a solution for monitoring and managing online services. The vulnerability lies in the improper validation of client-side stored data within the web application. Specifically, the is_master_admin key, stored in the local storage of the browser, can be manipulated by an attacker. By changing this key from false to true, the application grants administrative privileges to the user, without proper server-side validation.  This has been patched in 7.0.1815.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2024-29194?

4 open source packages ship an affected version, including @oneuptime/common-server and @oneuptime/model. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@oneuptime/common-server` | npm | All versions | 7.0.1815 |
| `@oneuptime/common-server` | npm | All versions | 7.0.1815 |
| `@oneuptime/model` | npm | All versions | 7.0.1815 |
| `@oneuptime/model` | npm | All versions | 7.0.1815 |

Products: Hackerbay Oneuptime.

## How do I fix CVE-2024-29194?

Upgrade @oneuptime/common-server to 7.0.1815 or later.

## Is CVE-2024-29194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29194 exists.

## Other vulnerabilities in oneuptime

- [CVE-2026-33396](https://insights.sbomify.com/CVE-2026-33396/): Code injection in oneuptime (critical 10.0)
- [CVE-2026-32306](https://insights.sbomify.com/CVE-2026-32306/): OneUptime ClickHouse SQL Injection via Aggregate Query Parameters (critical 10.0)
- [CVE-2026-30956](https://insights.sbomify.com/CVE-2026-30956/): OneUptime has authorization bypass via client‑controlled is-multi-tenant-query header (critical 10.0)
- [CVE-2026-30957](https://insights.sbomify.com/CVE-2026-30957/): OneUptime Synthetic Monitor RCE via exposed Playwright browser object (critical 10.0)
- [CVE-2026-30887](https://insights.sbomify.com/CVE-2026-30887/): OneUptime Affected by Unsandboxed Code Execution in Probe Allows Any Project Member to Achieve RCE (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29194 and fix it if it is affected.

What it is: CVE-2024-29194 is a high-severity vulnerability in oneuptime, published on 24 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29194 exists.

Affected packages and fixed versions:
- @oneuptime/common-server (npm): affected all versions; fixed in 7.0.1815
- @oneuptime/common-server (npm): affected all versions; fixed in 7.0.1815
- @oneuptime/model (npm): affected all versions; fixed in 7.0.1815
- @oneuptime/model (npm): affected all versions; fixed in 7.0.1815

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29194/ (Markdown: https://insights.sbomify.com/CVE-2024-29194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29194
- OSV: https://osv.dev/vulnerability/CVE-2024-29194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29194/
Summaries are generated and may contain mistakes; the official description above is the record.
