CVE-2024-29196 phpMyFAQ Path Traversal in Attachments
Administrators can exploit a path traversal flaw in phpMyFAQ to upload malicious files to arbitrary locations within the web root.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-29196?
CVE-2024-29196 is a low-severity path traversal vulnerability in Phpmyfaq Phpmyfaq, published on 26 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. There is a Path Traversal vulnerability in Attachments that allows attackers with admin rights to upload malicious files to other locations of the web root. This vulnerability is fixed in 3.2.6.
Weakness: CWE-22
Which versions are affected by CVE-2024-29196?
2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
phpmyfaq/phpmyfaq Packagist | From 3.2.5 | 3.2.6 |
Products include Phpmyfaq Phpmyfaq.
How do I fix CVE-2024-29196?
Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-29196 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29196 exists.
Other vulnerabilities in Phpmyfaq Phpmyfaq
- CVE-2023-0310 Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq
- CVE-2022-4407 Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq
- CVE-2017-11187 Security feature bypass in n/a
- CVE-2026-76213 phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- CVE-2026-76214 phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge
Sources
Also known as GHSA-mmh6-5cpf-2c72.