{"answers":{"affected":"2 open source packages ship an affected version, including phpmyfaq/phpmyfaq. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29196 exists.","fix":"Upgrade phpmyfaq/phpmyfaq to 3.2.6 or later.","what":"CVE-2024-29196 is a low-severity path traversal vulnerability in Phpmyfaq Phpmyfaq, published on 26 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29196 and fix it if it is affected.\n\nWhat it is: CVE-2024-29196 is a low-severity path traversal vulnerability in Phpmyfaq Phpmyfaq, published on 26 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29196 exists.\n\nAffected packages and fixed versions:\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n- phpmyfaq/phpmyfaq (Packagist): affected from 3.2.5; fixed in 3.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29196/ (Markdown: https://insights.sbomify.com/CVE-2024-29196/index.md)","id":"CVE-2024-29196","markdown":"https://insights.sbomify.com/CVE-2024-29196/index.md","name":"CVE-2024-29196","record":{"aliases":["GHSA-mmh6-5cpf-2c72"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyFAQ","requires_auth":"high_privilege","summary":"Administrators can exploit a path traversal flaw in phpMyFAQ to upload malicious files to arbitrary locations within the web root.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"phpmyfaq","vendor":"phpmyfaq"}],"cvss":{"score":3.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. There is a Path Traversal vulnerability in Attachments that allows attackers with admin rights to upload malicious files to other locations of the web root. This vulnerability is fixed in 3.2.6.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"phpMyFAQ Path Traversal in Attachments","id":"CVE-2024-29196","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyfaq:phpmyfaq","products":["phpmyfaq:phpmyfaq"],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Pimcore Preview Documents are not restricted to logged in users anymore","id":"CVE-2024-29197"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":null,"source":"GHSA-mmh6-5cpf-2c72"},{"ecosystem":"Packagist","fixed":["3.2.6"],"introduced":["3.2.5"],"last_affected":[],"package":"phpmyfaq/phpmyfaq","purl":"pkg:composer/phpmyfaq/phpmyfaq","source":"GHSA-mmh6-5cpf-2c72"}],"prev":{"headline":"Azure C SDK Integer Wraparound Vulnerability","id":"CVE-2024-29195"},"products":["phpMyFAQ"],"published":"2024-03-26","related":[{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0310","kev_date_added":null,"published":"2023-01-15"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq","id":"CVE-2022-4407","kev_date_added":null,"published":"2022-12-11"},{"cvss_score":9.8,"headline":"Security feature bypass in n/a","id":"CVE-2017-11187","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle","id":"CVE-2026-76213","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge","id":"CVE-2026-76214","kev_date_added":null,"published":"2026-08-19"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - DOM in thorsten/phpmyfaq","id":"CVE-2023-5316","kev_date_added":null,"published":"2023-09-30"},{"cvss_score":9.1,"headline":"Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq","id":"CVE-2023-0306","kev_date_added":null,"published":"2023-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-05","vendors":["thorsten"]},"summary":"Administrators can exploit a path traversal flaw in phpMyFAQ to upload malicious files to arbitrary locations within the web root.","url":"https://insights.sbomify.com/CVE-2024-29196/"}