# CVE-2024-29199: Unauthenticated views may expose information to anonymous users

> Unauthenticated users may access sensitive data if the EXEMPT_VIEW_PERMISSIONS configuration is modified from its default empty state.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-m732-wvh2-7cq4, PYSEC-2026-1687

## What is CVE-2024-29199?

CVE-2024-29199 is a low-severity vulnerability in nautobot, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nautobot is a Network Source of Truth and Network Automation Platform. A number of Nautobot URL endpoints were found to be improperly accessible to unauthenticated (anonymous) users. These endpoints will not disclose any Nautobot data to an unauthenticated user unless the Nautobot configuration variable EXEMPT_VIEW_PERMISSIONS is changed from its default value (an empty list) to permit access to specific data by unauthenticated users. This vulnerability is fixed in 1.6.16 and 2.1.9.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-29199?

5 open source packages ship an affected version, including nautobot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nautobot` | PyPI | All versions | 1.6.16, 2.1.9 |
| `nautobot` | PyPI | All versions | 1.6.16 |
| `nautobot` | PyPI | All versions | 1.6.16 |
| `nautobot` | PyPI | From 2.0.0 | 2.1.9 |
| `nautobot` | PyPI | From 2.0.0 | 2.1.9 |

Products: Networktocode Nautobot.

## How do I fix CVE-2024-29199?

Upgrade nautobot to a fixed version for your release line: 1.6.16 or 2.1.9.

## Is CVE-2024-29199 being exploited?

There is no known exploitation of CVE-2024-29199 in the wild and no public exploit code.

## Other vulnerabilities in nautobot

- [CVE-2026-44797](https://insights.sbomify.com/CVE-2026-44797/): Nautobot: Webhook definitions could be used for server-side request forgery (SSRF) (high 8.5)
- [CVE-2024-34707](https://insights.sbomify.com/CVE-2024-34707/): Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages (high 7.5)
- [CVE-2024-32979](https://insights.sbomify.com/CVE-2024-32979/): Reflected Cross-site Scripting potential in all object list views in Nautobot (high 7.5)
- [CVE-2023-25657](https://insights.sbomify.com/CVE-2023-25657/): Remote code execution in Jinja2 template rendering in Nautobot (high 7.5)
- [CVE-2026-44798](https://insights.sbomify.com/CVE-2026-44798/): Nautobot: GitRepository.current_head field should not be writable through REST API (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29199 and fix it if it is affected.

What it is: CVE-2024-29199 is a low-severity vulnerability in nautobot, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29199 in the wild and no public exploit code.

Affected packages and fixed versions:
- nautobot (PyPI): affected all versions; fixed in 1.6.16, 2.1.9
- nautobot (PyPI): affected all versions; fixed in 1.6.16
- nautobot (PyPI): affected all versions; fixed in 1.6.16
- nautobot (PyPI): affected from 2.0.0; fixed in 2.1.9
- nautobot (PyPI): affected from 2.0.0; fixed in 2.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29199/ (Markdown: https://insights.sbomify.com/CVE-2024-29199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29199
- OSV: https://osv.dev/vulnerability/CVE-2024-29199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29199/
Summaries are generated and may contain mistakes; the official description above is the record.
