# CVE-2024-29203: TinyMCE Cross-Site Scripting (XSS) vulnerability in handling iframes

> Attackers can inject malicious iframes into TinyMCE editors, triggering asset downloads or other operations via same-origin protections.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2024
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-438c-3975-5x3f, UBUNTU-CVE-2024-29203

## What is CVE-2024-29203?

CVE-2024-29203 is a medium-severity cross-site scripting vulnerability in tinymce, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

TinyMCE is an open source rich text editor. A cross-site scripting (XSS) vulnerability was discovered in TinyMCE’s content insertion code.  This allowed `iframe` elements containing malicious code to execute when inserted into the editor.  These `iframe` elements are restricted in their permissions by same-origin browser protections, but could still trigger operations such as downloading of malicious assets. This vulnerability is fixed in 6.8.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-29203?

6 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | All versions | 6.8.1 |
| `TinyMCE` | NuGet | All versions | 6.8.1 |
| `tinymce/tinymce` | Packagist | All versions | 6.8.1 |
| `tinymce/tinymce` | Packagist | All versions | 6.8.1 |
| `tinymce` | npm | All versions | 6.8.1 |
| `tinymce` | npm | All versions | 6.8.1 |

Products: Tiny Tinymce.

## How do I fix CVE-2024-29203?

Upgrade TinyMCE to 6.8.1 or later.

## Is CVE-2024-29203 being exploited?

There is no known exploitation of CVE-2024-29203 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29203 and fix it if it is affected.

What it is: CVE-2024-29203 is a medium-severity cross-site scripting vulnerability in tinymce, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29203 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected all versions; fixed in 6.8.1
- TinyMCE (NuGet): affected all versions; fixed in 6.8.1
- tinymce/tinymce (Packagist): affected all versions; fixed in 6.8.1
- tinymce/tinymce (Packagist): affected all versions; fixed in 6.8.1
- tinymce (npm): affected all versions; fixed in 6.8.1
- tinymce (npm): affected all versions; fixed in 6.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29203/ (Markdown: https://insights.sbomify.com/CVE-2024-29203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29203
- OSV: https://osv.dev/vulnerability/CVE-2024-29203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29203/
Summaries are generated and may contain mistakes; the official description above is the record.
