CVE-2024-29221 Invite ID available to team admins even without the "Add Members" permission

Medium 4.7 Published Updated

Team admins can bypass permission restrictions to obtain invite IDs and add members, undermining access control policies in Mattermost.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29221?

CVE-2024-29221 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 5 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Improper Access Control in Mattermost Server versions 9.5.x before 9.5.2, 9.4.x before 9.4.4, 9.3.x before 9.3.3, 8.1.x before 8.1.11 lacked proper access control in the `/api/v4/users/me/teams` endpoint allowing a team admin to get the invite ID of their team, thus allowing them to invite users, even if the "Add Members" permission was explicitly removed from team admins.

Weakness: CWE-284

Which versions are affected by CVE-2024-29221?

13 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 8.1.08.1.11
github.com/mattermost/mattermost/server/v8 GoFrom 8.1.08.1.11
github.com/mattermost/mattermost/server/v8 GoFrom 9.3.09.3.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.3.09.3.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.4.09.4.4
7 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.4.09.4.4
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.2
mattermost BitnamiFrom 8.1.08.1.11, 9.3.3, 9.4.4, 9.5.2
github.com/mattermost/mattermost-server GoFrom 9.3.0+incompatible9.3.3+incompatible, 9.4.4+incompatible, 9.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2024-29221?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.1.11, 9.3.3, 9.4.4 or 9.5.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-29221 being exploited?

There is no known exploitation of CVE-2024-29221 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as BIT-mattermost-2024-29221, GHSA-w67v-ph4x-f48q, GO-2024-2706.

Is CVE-2024-29221 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free