# CVE-2024-29271: VvvebJs Reflected Cross-Site Scripting (XSS) vulnerability

> Remote attackers can execute arbitrary code and access sensitive information via a reflected XSS vulnerability in the save.php action parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Mar 2024
- **Updated:** 28 Aug 2024
- **Also known as:** GHSA-pc95-3wgm-x28p

## What is CVE-2024-29271?

CVE-2024-29271 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Reflected Cross-Site Scripting (XSS) vulnerability in VvvebJs before version 1.7.7, allows remote attackers to execute arbitrary code and obtain sensitive information via the action parameter in save.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-29271?

2 open source packages ship an affected version, including vvvebjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vvvebjs` | npm | All versions | 1.7.5 |
| `vvvebjs` | npm | All versions | 1.7.5 |

Products: Vvveb Vvvebjs.

## How do I fix CVE-2024-29271?

Upgrade vvvebjs to 1.7.5 or later.

## Is CVE-2024-29271 being exploited?

There is no known exploitation of CVE-2024-29271 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-25182](https://insights.sbomify.com/CVE-2024-25182/): File upload in n/a (critical 9.8)
- [CVE-2024-27480](https://insights.sbomify.com/CVE-2024-27480/): File upload in n/a (critical 9.8)
- [CVE-2024-25181](https://insights.sbomify.com/CVE-2024-25181/): Server-side request forgery in n/a (critical 9.1)
- [CVE-2024-25183](https://insights.sbomify.com/CVE-2024-25183/): Path traversal in n/a (high 7.5)
- [CVE-2024-29272](https://insights.sbomify.com/CVE-2024-29272/): VvvebJs Arbitrary File Upload vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29271 and fix it if it is affected.

What it is: CVE-2024-29271 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29271 in the wild and no public exploit code.

Affected packages and fixed versions:
- vvvebjs (npm): affected all versions; fixed in 1.7.5
- vvvebjs (npm): affected all versions; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29271/ (Markdown: https://insights.sbomify.com/CVE-2024-29271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29271
- OSV: https://osv.dev/vulnerability/CVE-2024-29271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29271/
Summaries are generated and may contain mistakes; the official description above is the record.
