# CVE-2024-2928: Local File Inclusion (LFI) via URI Fragment Parsing in mlflow/mlflow

> An attacker can read arbitrary local files by manipulating URI fragments in MLflow, bypassing previous validation patches.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mlflow-2024-2928, GHSA-j46q-5pxx-8vmw, PYSEC-2024-242

## What is CVE-2024-2928?

CVE-2024-2928 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Local File Inclusion (LFI) vulnerability was identified in mlflow/mlflow, specifically in version 2.9.2, which was fixed in version 2.11.3. This vulnerability arises from the application's failure to properly validate URI fragments for directory traversal sequences such as '../'. An attacker can exploit this flaw by manipulating the fragment part of the URI to read arbitrary files on the local file system, including sensitive files like '/etc/passwd'. The vulnerability is a bypass to a previous patch that only addressed similar manipulation within the URI's query string, highlighting the need for comprehensive validation of all parts of a URI to prevent LFI attacks.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2024-2928?

4 open source packages ship an affected version, including mlflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mlflow` | Bitnami | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions | 2.11.3 |
| `mlflow` | PyPI | All versions | 2.11.3 |

Products: Lfprojects Mlflow.

## How do I fix CVE-2024-2928?

Upgrade mlflow to 2.11.3 or later.

## Is CVE-2024-2928 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2928 exists.

Public exploit code:

- Arbitrary file read exploit for CVE-2024-2928 in mlflow  (github_poc): https://github.com/nuridincersaygili/CVE-2024-2928
- yasa扫描sjtu_CVE-2024-2928漏洞报告 (github_poc): https://github.com/rain321654/sjtu_CVE-2024-2928
- MLflow < 2.11.3 - Path Traversal (nuclei): http/cves/2024/CVE-2024-2928.yaml

## Other vulnerabilities in Lfprojects Mlflow

- [CVE-2026-64849](https://insights.sbomify.com/CVE-2026-64849/): MLflow Server-Side Request Forgery (critical 9.3, exploited in the wild)
- [CVE-2025-15379](https://insights.sbomify.com/CVE-2025-15379/): Command Injection in mlflow/mlflow (critical 10.0)
- [CVE-2024-0520](https://insights.sbomify.com/CVE-2024-0520/): Remote Code Execution due to Full Controlled File Write in mlflow/mlflow (critical 10.0)
- [CVE-2023-6977](https://insights.sbomify.com/CVE-2023-6977/): Path Traversal: '\..\filename' (critical 10.0)
- [CVE-2023-6709](https://insights.sbomify.com/CVE-2023-6709/): Improper Neutralization of Special Elements Used in a Template Engine in mlflow/mlflow (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2928 and fix it if it is affected.

What it is: CVE-2024-2928 is a high-severity path traversal vulnerability in Lfprojects Mlflow, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2928 exists.

Affected packages and fixed versions:
- mlflow (Bitnami): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions; fixed in 2.11.3
- mlflow (PyPI): affected all versions; fixed in 2.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2928/ (Markdown: https://insights.sbomify.com/CVE-2024-2928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2928
- OSV: https://osv.dev/vulnerability/CVE-2024-2928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2928/
Summaries are generated and may contain mistakes; the official description above is the record.
