# CVE-2024-29316: Incorrect Access Control in NodeBB

> Low-privileged attackers can access restricted admin tabs by manipulating the isadmin parameter, leading to unauthorized privilege escalation.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2024
- **Updated:** 15 Nov 2024
- **Also known as:** GHSA-qc99-r4wh-c8h6

## What is CVE-2024-29316?

CVE-2024-29316 is a medium-severity missing authorization vulnerability in n/a, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NodeBB 3.6.7 is vulnerable to Incorrect Access Control, e.g., a low-privileged attacker can access the restricted tabs for the Admin group via "isadmin":true.

## Which versions are affected by CVE-2024-29316?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 3.6.7 |
| `nodebb` | npm | All versions | 3.6.7 |

Products: Nodebb Nodebb.

## How do I fix CVE-2024-29316?

Upgrade nodebb to 3.6.7 or later.

## Is CVE-2024-29316 being exploited?

There is no known exploitation of CVE-2024-29316 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29316 and fix it if it is affected.

What it is: CVE-2024-29316 is a medium-severity missing authorization vulnerability in n/a, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29316 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 3.6.7
- nodebb (npm): affected all versions; fixed in 3.6.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29316/ (Markdown: https://insights.sbomify.com/CVE-2024-29316/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29316
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29316
- OSV: https://osv.dev/vulnerability/CVE-2024-29316

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29316/
Summaries are generated and may contain mistakes; the official description above is the record.
