{"answers":{"affected":"3 open source packages ship an affected version, including python-jose. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29370 exists.","fix":"Upgrade python-jose to 3.4.0 or later.","what":"CVE-2024-29370 is a medium-severity denial of service vulnerability in n/a, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29370 and fix it if it is affected.\n\nWhat it is: CVE-2024-29370 is a medium-severity denial of service vulnerability in n/a, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29370 exists.\n\nAffected packages and fixed versions:\n- python-jose (PyPI): affected all versions up to 3.3.0; no fix listed\n- python-jose (PyPI): affected all versions; fixed in 3.4.0\n- python-jose (PyPI): affected all versions; fixed in 3.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29370/ (Markdown: https://insights.sbomify.com/CVE-2024-29370/index.md)","id":"CVE-2024-29370","markdown":"https://insights.sbomify.com/CVE-2024-29370/index.md","name":"CVE-2024-29370","record":{"aliases":["DEBIAN-CVE-2024-29370","GHSA-h4pw-wxh7-4vjj","PYSEC-2025-185","UBUNTU-CVE-2024-29370"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python JWE library","requires_auth":"none","summary":"An attacker can cause a Denial-of-Service in python-jose by sending a malicious JWE token with high compression, leading to excessive memory usage.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"python-jose","vendor":"python-jose_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"In python-jose 3.3.0 (specifically jwe.decrypt), a vulnerability allows an attacker to cause a Denial-of-Service (DoS) condition by crafting a malicious JSON Web Encryption (JWE) token with an exceptionally high compression ratio. When this token is processed by the server, it results in significant memory allocation and processing time during decompression.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Duplicate Advisory: python-jose denial of service via compressed JWE content","id":"CVE-2024-29370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"jose4j is vulnerable to DoS via compressed JWE content","id":"CVE-2024-29371"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["3.3.0"],"package":"python-jose","purl":"pkg:pypi/python-jose","source":"PYSEC-2025-185"},{"ecosystem":"PyPI","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"python-jose","purl":null,"source":"GHSA-h4pw-wxh7-4vjj"},{"ecosystem":"PyPI","fixed":["3.4.0"],"introduced":["0"],"last_affected":[],"package":"python-jose","purl":"pkg:pypi/python-jose","source":"GHSA-h4pw-wxh7-4vjj"}],"prev":{"headline":"File upload in n/a","id":"CVE-2024-29368"},"products":["n/a"],"published":"2025-12-17","related":[{"cvss_score":9.8,"headline":"python-jose failure to use a constant time comparison for HMAC keys","id":"CVE-2016-7036","kev_date_added":null,"published":"2017-01-23"},{"cvss_score":6.5,"headline":"Security feature bypass in n/a","id":"CVE-2024-33663","kev_date_added":null,"published":"2024-04-25"},{"cvss_score":5.3,"headline":"python-jose denial of service via compressed JWE content","id":"CVE-2024-33664","kev_date_added":null,"published":"2024-04-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-12-17","vendors":["n/a"]},"summary":"An attacker can cause a Denial-of-Service in python-jose by sending a malicious JWE token with high compression, leading to excessive memory usage.","url":"https://insights.sbomify.com/CVE-2024-29370/"}