# CVE-2024-29370: Duplicate Advisory: python-jose denial of service via compressed JWE content

> An attacker can cause a Denial-of-Service in python-jose by sending a malicious JWE token with high compression, leading to excessive memory usage.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 17 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** DEBIAN-CVE-2024-29370, GHSA-h4pw-wxh7-4vjj, PYSEC-2025-185, UBUNTU-CVE-2024-29370

## What is CVE-2024-29370?

CVE-2024-29370 is a medium-severity denial of service vulnerability in n/a, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In python-jose 3.3.0 (specifically jwe.decrypt), a vulnerability allows an attacker to cause a Denial-of-Service (DoS) condition by crafting a malicious JSON Web Encryption (JWE) token with an exceptionally high compression ratio. When this token is processed by the server, it results in significant memory allocation and processing time during decompression.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2024-29370?

3 open source packages ship an affected version, including python-jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-jose` | PyPI | All versions to 3.3.0 | None |
| `python-jose` | PyPI | All versions | 3.4.0 |
| `python-jose` | PyPI | All versions | 3.4.0 |

Products: Python-Jose Project Python-Jose.

## How do I fix CVE-2024-29370?

Upgrade python-jose to 3.4.0 or later.

## Is CVE-2024-29370 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29370 exists.

## Other vulnerabilities in n/a

- [CVE-2016-7036](https://insights.sbomify.com/CVE-2016-7036/): python-jose failure to use a constant time comparison for HMAC keys (critical 9.8)
- [CVE-2024-33663](https://insights.sbomify.com/CVE-2024-33663/): Security feature bypass in n/a (medium 6.5)
- [CVE-2024-33664](https://insights.sbomify.com/CVE-2024-33664/): python-jose denial of service via compressed JWE content (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29370 and fix it if it is affected.

What it is: CVE-2024-29370 is a medium-severity denial of service vulnerability in n/a, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29370 exists.

Affected packages and fixed versions:
- python-jose (PyPI): affected all versions up to 3.3.0; no fix listed
- python-jose (PyPI): affected all versions; fixed in 3.4.0
- python-jose (PyPI): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29370/ (Markdown: https://insights.sbomify.com/CVE-2024-29370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29370
- OSV: https://osv.dev/vulnerability/CVE-2024-29370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29370/
Summaries are generated and may contain mistakes; the official description above is the record.
