{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29374 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-29374 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-29374 and fix it if it is affected.\n\nWhat it is: CVE-2024-29374 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 21 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29374 exists.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions up to 3.10.9; no fix listed\n- moodle/moodle (Packagist): affected all versions up to 3.10.9; no fix listed\n- moodle (Bitnami): affected from 3.10.9; fixed in 4.1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29374/ (Markdown: https://insights.sbomify.com/CVE-2024-29374/index.md)","id":"CVE-2024-29374","markdown":"https://insights.sbomify.com/CVE-2024-29374/index.md","name":"CVE-2024-29374","record":{"aliases":["BIT-moodle-2024-29374","GHSA-3qw5-v9cc-v262","UBUNTU-CVE-2024-29374"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can execute arbitrary scripts in victim browsers via the lang parameter, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A Cross-Site Scripting (XSS) vulnerability exists in the way MOODLE 3.10.9 handles user input within the \"GET /?lang=\" URL parameter.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross site scripting in moodle","id":"CVE-2024-29374","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"Code injection in n/a","id":"CVE-2024-29375"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.10"],"introduced":["3.10.9"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2024-29374"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.10.9"],"package":"moodle/moodle","purl":null,"source":"GHSA-3qw5-v9cc-v262"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["3.10.9"],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-3qw5-v9cc-v262"}],"prev":{"headline":"jose4j is vulnerable to DoS via compressed JWE content","id":"CVE-2024-29371"},"products":["n/a"],"published":"2024-03-21","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-15","vendors":["n/a"]},"summary":"Attackers can execute arbitrary scripts in victim browsers via the lang parameter, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2024-29374/"}