# CVE-2024-29477: Dolibarr ERP CRM Code Injection vulnerability during installation

> An attacker with adjacent network access can execute arbitrary code during the Dolibarr ERP CRM installation process due to insufficient input sanitization.

- **Severity:** High 8.8 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2024
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-dolibarr-2024-29477, GHSA-p73x-rpgm-3v56, UBUNTU-CVE-2024-29477

## What is CVE-2024-29477?

CVE-2024-29477 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Lack of sanitization during Installation Process in Dolibarr ERP CRM up to version 19.0.0 allows an attacker with adjacent access to the network to execute arbitrary code via a specifically crafted input.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-29477?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions to 19.0.0 | None |
| `dolibarr/dolibarr` | Packagist | All versions to 19.0.0 | None |
| `dolibarr` | Bitnami | All versions | 19.0.1 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2024-29477?

Upgrade to a fixed version.

## Is CVE-2024-29477 being exploited?

There is no known exploitation of CVE-2024-29477 in the wild and no public exploit code.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29477 and fix it if it is affected.

What it is: CVE-2024-29477 is a high-severity code injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 3 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29477 in the wild and no public exploit code.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions up to 19.0.0; no fix listed
- dolibarr/dolibarr (Packagist): affected all versions up to 19.0.0; no fix listed
- dolibarr (Bitnami): affected all versions; fixed in 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29477/ (Markdown: https://insights.sbomify.com/CVE-2024-29477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29477
- OSV: https://osv.dev/vulnerability/CVE-2024-29477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29477/
Summaries are generated and may contain mistakes; the official description above is the record.
