{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29508 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2024-29508 is a low-severity vulnerability in Artifex Ghostscript, published on 3 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29508 and fix it if it is affected.\n\nWhat it is: CVE-2024-29508 is a low-severity vulnerability in Artifex Ghostscript, published on 3 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29508 in the wild and no public exploit code.\n\nAffected product: Artifex Ghostscript. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29508/ (Markdown: https://insights.sbomify.com/CVE-2024-29508/index.md)","id":"CVE-2024-29508","markdown":"https://insights.sbomify.com/CVE-2024-29508/index.md","name":"CVE-2024-29508","record":{"aliases":["BELL-CVE-2024-29508","CLSA-2026-1776333493","DEBIAN-CVE-2024-29508","DLA-3931-1","GHSA-w2wv-53w9-5r3r","OESA-2024-2160","OESA-2024-2161","SUSE-SU-2024:2547-1","SUSE-SU-2024:2627-1","UBUNTU-CVE-2024-29508"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ghostscript library","requires_auth":"low_privilege","summary":"An attacker can disclose heap memory contents via a crafted BaseFont name in Ghostscript, potentially leaking sensitive data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ghostscript","vendor":"artifex"}],"cvss":{"score":3.3,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Artifex Ghostscript before 10.03.0 has a heap-based pointer disclosure (observable in a constructed BaseFont name) in the function pdf_base_font_alloc.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15 SP5","SUSE:Linux Enterprise Module for Basesystem 15 SP6","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.5","openSUSE:Leap 15.6"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2024-29508","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"artifex:ghostscript","products":["artifex:ghostscript"],"type":"information_disclosure","year":"2024"},"n_packages":7,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2024-29509"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP5","fixed":["9.52-150000.197.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP5","source":"SUSE-SU-2024:2627-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP6","fixed":["9.52-150000.197.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP6","source":"SUSE-SU-2024:2627-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["9.52-23.83.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:2547-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["9.52-23.83.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:2547-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["9.52-23.83.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2024:2547-1"},{"ecosystem":"openSUSE:Leap 15.5","fixed":["9.52-150000.197.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/opensuse/ghostscript\u0026distro=openSUSE%20Leap%2015.5","source":"SUSE-SU-2024:2627-1"},{"ecosystem":"openSUSE:Leap 15.6","fixed":["9.52-150000.197.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/opensuse/ghostscript\u0026distro=openSUSE%20Leap%2015.6","source":"SUSE-SU-2024:2627-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2024-29507"},"products":["n/a"],"published":"2024-07-03","related":[{"cvss_score":7.8,"headline":"Artifex Ghostscript Type Confusion","id":"CVE-2017-8291","kev_date_added":"2022-05-24","published":"2017-04-27"},{"cvss_score":9.9,"headline":"Command injection in ghostscript","id":"CVE-2021-3781","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27831","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27832","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27836","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"An issue was discovered in Artifex Ghostscript before 10.05.0.","id":"CVE-2025-27837","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-36773","kev_date_added":null,"published":"2024-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-17","vendors":["n/a"]},"summary":"An attacker can disclose heap memory contents via a crafted BaseFont name in Ghostscript, potentially leaking sensitive data.","url":"https://insights.sbomify.com/CVE-2024-29508/"}