{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2952 exists.","fix":"Upgrade litellm to 1.34.42 or later.","what":"CVE-2024-2952 is a critical code injection vulnerability in berriai/litellm, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2952 and fix it if it is affected.\n\nWhat it is: CVE-2024-2952 is a critical code injection vulnerability in berriai/litellm, published on 10 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2952 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.34.42\n- litellm (PyPI): affected all versions; fixed in 1.34.42\n- litellm (PyPI): affected all versions; fixed in 1.34.42\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2952/ (Markdown: https://insights.sbomify.com/CVE-2024-2952/index.md)","id":"CVE-2024-2952","markdown":"https://insights.sbomify.com/CVE-2024-2952/index.md","name":"CVE-2024-2952","record":{"aliases":["GHSA-46cm-pfwv-cgf8","PYSEC-2026-387"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"none","summary":"Attackers can execute arbitrary code on the server by exploiting Server-Side Template Injection in the LiteLLM library via malicious tokenizer configurations.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-76","name":"Improper Neutralization of Equivalent Special Elements"}],"description":"BerriAI/litellm is vulnerable to Server-Side Template Injection (SSTI) via the `/completions` endpoint. The vulnerability arises from the `hf_chat_template` method processing the `chat_template` parameter from the `tokenizer_config.json` file through the Jinja template engine without proper sanitization. Attackers can exploit this by crafting malicious `tokenizer_config.json` files that execute arbitrary code on the server.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"LuckyWP Table of Contents \u003c= 2.1.4 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2024-2953"},"packages":[{"ecosystem":"PyPI","fixed":["1.34.42"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-46cm-pfwv-cgf8"},{"ecosystem":"PyPI","fixed":["1.34.42"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-46cm-pfwv-cgf8"},{"ecosystem":"PyPI","fixed":["1.34.42"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-387"}],"prev":{"headline":"WordPress RegistrationMagic plugin \u003c= 5.3.0.0 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-2951"},"products":["berriai/litellm"],"published":"2024-04-10","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["berriai"]},"summary":"Attackers can execute arbitrary code on the server by exploiting Server-Side Template Injection in the LiteLLM library via malicious tokenizer configurations.","url":"https://insights.sbomify.com/CVE-2024-2952/"}