{"answers":{"affected":"6 open source packages ship an affected version, including langchain and langchain-community. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2965 exists.","fix":"Upgrade langchain to 0.2.5 or later.","what":"CVE-2024-2965 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-2965 and fix it if it is affected.\n\nWhat it is: CVE-2024-2965 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2965 exists.\n\nAffected packages and fixed versions:\n- langchain (PyPI): affected all versions; fixed in 0.2.5\n- langchain (PyPI): affected all versions; fixed in 0.2.5\n- langchain (PyPI): affected all versions; fixed in 0.2.5\n- langchain-community (PyPI): affected all versions; fixed in 0.2.5\n- langchain-community (PyPI): affected all versions; fixed in 0.2.5\n- langchain-community (PyPI): affected all versions; fixed in 0.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2965/ (Markdown: https://insights.sbomify.com/CVE-2024-2965/index.md)","id":"CVE-2024-2965","markdown":"https://insights.sbomify.com/CVE-2024-2965/index.md","name":"CVE-2024-2965","record":{"aliases":["GHSA-3hjh-jh2h-vrg6","PYSEC-2024-118","PYSEC-2026-2561"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python AI framework","requires_auth":"none","summary":"Attackers can cause a crash and resource exhaustion in LangChain's SitemapLoader by triggering infinite recursion via self-referencing sitemaps.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:P/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"A Denial-of-Service (DoS) vulnerability exists in the `SitemapLoader` class of the `langchain-ai/langchain` repository, affecting all versions. The `parse_sitemap` method, responsible for parsing sitemaps and extracting URLs, lacks a mechanism to prevent infinite recursion when a sitemap URL refers to the current sitemap itself. This oversight allows for the possibility of an infinite loop, leading to a crash by exceeding the maximum recursion depth in Python. This vulnerability can be exploited to occupy server socket/port resources and crash the Python process, impacting the availability of services relying on this functionality.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial-of-Service in LangChain SitemapLoader in langchain-ai/langchain","id":"CVE-2024-2965","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":6,"n_references":2,"next":{"headline":"Information disclosure in Element Pack – Widgets, Templates \u0026 Addons for Elementor","id":"CVE-2024-2966"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":null,"source":"GHSA-3hjh-jh2h-vrg6"},{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"GHSA-3hjh-jh2h-vrg6"},{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"PYSEC-2024-118"},{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":null,"source":"GHSA-3hjh-jh2h-vrg6"},{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"GHSA-3hjh-jh2h-vrg6"},{"ecosystem":"PyPI","fixed":["0.2.5"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"PYSEC-2026-2561"}],"prev":{"headline":"Pocket News Generator \u003c= 0.2.0 - Cross-Site Request Forgery to Settings Update","id":"CVE-2024-2964"},"products":["langchain-ai/langchain"],"published":"2024-06-06","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["langchain-ai"]},"summary":"Attackers can cause a crash and resource exhaustion in LangChain's SitemapLoader by triggering infinite recursion via self-referencing sitemaps.","url":"https://insights.sbomify.com/CVE-2024-2965/"}