# CVE-2024-2965: Denial-of-Service in LangChain SitemapLoader in langchain-ai/langchain

> Attackers can cause a crash and resource exhaustion in LangChain's SitemapLoader by triggering infinite recursion via self-referencing sitemaps.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:P/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jun 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-3hjh-jh2h-vrg6, PYSEC-2024-118, PYSEC-2026-2561

## What is CVE-2024-2965?

CVE-2024-2965 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Denial-of-Service (DoS) vulnerability exists in the `SitemapLoader` class of the `langchain-ai/langchain` repository, affecting all versions. The `parse_sitemap` method, responsible for parsing sitemaps and extracting URLs, lacks a mechanism to prevent infinite recursion when a sitemap URL refers to the current sitemap itself. This oversight allows for the possibility of an infinite loop, leading to a crash by exceeding the maximum recursion depth in Python. This vulnerability can be exploited to occupy server socket/port resources and crash the Python process, impacting the availability of services relying on this functionality.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2024-2965?

6 open source packages ship an affected version, including langchain and langchain-community. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain` | PyPI | All versions | 0.2.5 |
| `langchain` | PyPI | All versions | 0.2.5 |
| `langchain` | PyPI | All versions | 0.2.5 |
| `langchain-community` | PyPI | All versions | 0.2.5 |
| `langchain-community` | PyPI | All versions | 0.2.5 |
| `langchain-community` | PyPI | All versions | 0.2.5 |

Products: Langchain Langchain.

## How do I fix CVE-2024-2965?

Upgrade langchain to 0.2.5 or later.

## Is CVE-2024-2965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2965 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2965 and fix it if it is affected.

What it is: CVE-2024-2965 is a medium-severity denial of service vulnerability in langchain-ai/langchain, published on 6 Jun 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2965 exists.

Affected packages and fixed versions:
- langchain (PyPI): affected all versions; fixed in 0.2.5
- langchain (PyPI): affected all versions; fixed in 0.2.5
- langchain (PyPI): affected all versions; fixed in 0.2.5
- langchain-community (PyPI): affected all versions; fixed in 0.2.5
- langchain-community (PyPI): affected all versions; fixed in 0.2.5
- langchain-community (PyPI): affected all versions; fixed in 0.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2965/ (Markdown: https://insights.sbomify.com/CVE-2024-2965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2965
- OSV: https://osv.dev/vulnerability/CVE-2024-2965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2965/
Summaries are generated and may contain mistakes; the official description above is the record.
