CVE-2024-29650 @thi.ng/paths Prototype Pollution vulnerability
Critical 9.8
Published
Updated
Check this codebase for CVE-2024-29650 and fix it if it is affected.
What it is: CVE-2024-29650 is a critical vulnerability in n/a, published on 25 Mar 2024.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29650 exists.
Affected packages and fixed versions:
- @thi.ng/paths (npm): affected all versions; fixed in 5.1.63
- @thi.ng/paths (npm): affected all versions; fixed in 5.1.63
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2024-29650/ (Markdown: https://insights.sbomify.com/CVE-2024-29650/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-29650?
CVE-2024-29650 is a critical vulnerability in n/a, published on 25 Mar 2024.
Official description
An issue in @thi.ng/paths v.5.1.62 and before allows a remote attacker to execute arbitrary code via the mutIn and mutInManyUnsafe components.
Weakness: CWE-1321
Which versions are affected by CVE-2024-29650?
2 open source packages ship an affected version, including @thi.ng/paths.
| Package | Affected | Fixed in |
|---|---|---|
@thi.ng/paths npm | All versions | 5.1.63 |
@thi.ng/paths npm | All versions | 5.1.63 |
How do I fix CVE-2024-29650?
Upgrade @thi.ng/paths to 5.1.63 or later.
Is CVE-2024-29650 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29650 exists.
Sources
Also known as GHSA-8ppr-www8-hfjx.