# CVE-2024-29650: @thi.ng/paths Prototype Pollution vulnerability


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Mar 2024
- **Updated:** 23 Aug 2024
- **Also known as:** GHSA-8ppr-www8-hfjx

## What is CVE-2024-29650?

CVE-2024-29650 is a critical vulnerability in n/a, published on 25 Mar 2024. 

### Official description

An issue in @thi.ng/paths v.5.1.62 and before allows a remote attacker to execute arbitrary code via the mutIn and mutInManyUnsafe components.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-29650?

2 open source packages ship an affected version, including @thi.ng/paths.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@thi.ng/paths` | npm | All versions | 5.1.63 |
| `@thi.ng/paths` | npm | All versions | 5.1.63 |

## How do I fix CVE-2024-29650?

Upgrade @thi.ng/paths to 5.1.63 or later.

## Is CVE-2024-29650 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29650 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29650 and fix it if it is affected.

What it is: CVE-2024-29650 is a critical vulnerability in n/a, published on 25 Mar 2024. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29650 exists.

Affected packages and fixed versions:
- @thi.ng/paths (npm): affected all versions; fixed in 5.1.63
- @thi.ng/paths (npm): affected all versions; fixed in 5.1.63

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29650/ (Markdown: https://insights.sbomify.com/CVE-2024-29650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29650
- OSV: https://osv.dev/vulnerability/CVE-2024-29650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29650/
Summaries are generated and may contain mistakes; the official description above is the record.
