{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-ftp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29733 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-ftp to 3.7.0 or later.","what":"CVE-2024-29733 is a low-severity vulnerability in Apache Airflow FTP Provider, published on 21 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29733 and fix it if it is affected.\n\nWhat it is: CVE-2024-29733 is a low-severity vulnerability in Apache Airflow FTP Provider, published on 21 Apr 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29733 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-ftp (PyPI): affected all versions; fixed in 3.7.0\n- apache-airflow-providers-ftp (PyPI): affected all versions; fixed in 3.7.0\n- apache-airflow-providers-ftp (PyPI): affected all versions; fixed in 3.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29733/ (Markdown: https://insights.sbomify.com/CVE-2024-29733/index.md)","id":"CVE-2024-29733","markdown":"https://insights.sbomify.com/CVE-2024-29733/index.md","name":"CVE-2024-29733","record":{"aliases":["ECHO-b395-a7ab-d901","GHSA-3gg8-mc87-cq3h","PYSEC-2026-1148"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Airflow FTP Provider","requires_auth":"high_privilege","summary":"An attacker can bypass SSL certificate validation in Apache Airflow FTP connections, potentially enabling man-in-the-middle attacks.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-ftp","vendor":"apache"}],"cvss":{"score":2.7,"severity":"low","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Improper Certificate Validation vulnerability in Apache Airflow FTP Provider.\n\nThe FTP hook lacks complete certificate validation in FTP_TLS connections, which can potentially be leveraged. Implementing proper certificate validation by passing context=ssl.create_default_context() during FTP_TLS instantiation is used as mitigation to validate the certificates properly.\n\nThis issue affects Apache Airflow FTP Provider: before 3.7.0.\n\nUsers are recommended to upgrade to version 3.7.0, which fixes the issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow FTP Provider: FTP_TLS instance with unverified SSL context","id":"CVE-2024-29733","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"Other in SonicDICOM Media Viewer","id":"CVE-2024-29734"},"packages":[{"ecosystem":"PyPI","fixed":["3.7.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-ftp","purl":null,"source":"GHSA-3gg8-mc87-cq3h"},{"ecosystem":"PyPI","fixed":["3.7.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-ftp","purl":"pkg:pypi/apache-airflow-providers-ftp","source":"GHSA-3gg8-mc87-cq3h"},{"ecosystem":"PyPI","fixed":["3.7.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-ftp","purl":"pkg:pypi/apache-airflow-providers-ftp","source":"PYSEC-2026-1148"}],"prev":{"headline":"SQL Injection vulnerability on SCAN_VISIO eDocument Suite Web Viewer from Abast","id":"CVE-2024-29732"},"products":["Apache Airflow FTP Provider"],"published":"2024-04-21","related":[{"cvss_score":7.5,"headline":"Apache Airflow FTP provider: FTP Provider does not protect FTPS data channel (missing PROT_P)","id":"CVE-2026-49486","kev_date_added":null,"published":"2026-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker can bypass SSL certificate validation in Apache Airflow FTP connections, potentially enabling man-in-the-middle attacks.","url":"https://insights.sbomify.com/CVE-2024-29733/"}