# CVE-2024-29735: Apache Airflow: Potentially harmful permission changing by log task handler

> Apache Airflow incorrectly sets group write permissions on log directories, potentially allowing unauthorized access or privilege escalation in non-containerized environments.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-airflow-2024-29735, GHSA-cff3-5qrp-hqx7, PYSEC-2026-1132

## What is CVE-2024-29735?

CVE-2024-29735 is a medium-severity vulnerability in Apache Airflow, published on 26 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Preservation of Permissions vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.8.2 through 2.8.3.

Airflow's local file task handler in Airflow incorrectly set permissions for all parent folders of log folder, in default configuration adding write access to Unix group of the folders. In the case Airflow is run with the root user (not recommended) it added group write permission to all folders up to the root of the filesystem.

If your log files are stored in the home directory, these permission changes might impact your ability to run SSH operations after your home directory becomes group-writeable.

This issue does not affect users who use or extend Airflow using Official Airflow Docker reference images ( https://hub.docker.com/r/apache/airflow/ ) - those images require to have group write permission set anyway.

You are affected only if you install Airflow using local installation / virtualenv or other Docker images, but the issue has no impact if docker containers are used as intended, i.e. where Airflow components do not share containers with other applications and users.

Also you should not be affected if your umask is 002 (group write enabled) - this is the default on many linux systems.

Recommendation for users using Airflow outside of the containers:

  *  if you are using root to run Airflow, change your Airflow user to use non-root
  *  upgrade Apache Airflow to 2.8.4 or above
  *  If you prefer not to upgrade, you can change the  https://airflow.apache.org/docs/apache-airflow/stable/configurations-ref.html#file-task-handler-new-folder-permissions  to 0o755 (original value 0o775).
  *  if you already ran Airflow tasks before and your default umask is 022 (group write disabled) you should stop Airflow components, check permissions of AIRFLOW_HOME/logs in all your components and all parent directories of this directory and remove group write access for all the parent directories

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2024-29735?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | From 2.8.2 | 2.8.4 |
| `apache-airflow` | PyPI | From 2.8.2 | 2.8.4 |
| `apache-airflow` | PyPI | From 2.8.2 | 2.8.4 |
| `airflow` | Bitnami | From 2.8.2 | 2.8.4 |

Products: Apache Airflow.

## How do I fix CVE-2024-29735?

Upgrade apache-airflow to 2.8.4 or later.

## Is CVE-2024-29735 being exploited?

There is no known exploitation of CVE-2024-29735 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29735 and fix it if it is affected.

What it is: CVE-2024-29735 is a medium-severity vulnerability in Apache Airflow, published on 26 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29735 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected from 2.8.2; fixed in 2.8.4
- apache-airflow (PyPI): affected from 2.8.2; fixed in 2.8.4
- apache-airflow (PyPI): affected from 2.8.2; fixed in 2.8.4
- airflow (Bitnami): affected from 2.8.2; fixed in 2.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29735/ (Markdown: https://insights.sbomify.com/CVE-2024-29735/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29735
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29735
- OSV: https://osv.dev/vulnerability/CVE-2024-29735

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29735/
Summaries are generated and may contain mistakes; the official description above is the record.
