{"answers":{"affected":"6 open source packages ship an affected version, including timber/timber.","exploited":"There is no known exploitation of CVE-2024-29800 in the wild and no public exploit code.","fix":"Upgrade timber/timber to a fixed version for your release line: 1.23.1, 1.24.1 or 2.1.0.","what":"CVE-2024-29800 is a high-severity unsafe deserialization vulnerability in Timber, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29800 and fix it if it is affected.\n\nWhat it is: CVE-2024-29800 is a high-severity unsafe deserialization vulnerability in Timber, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29800 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- timber/timber (Packagist): affected from 0.16.6; fixed in 1.23.1\n- timber/timber (Packagist): affected from 0.16.6; fixed in 1.23.1\n- timber/timber (Packagist): affected from 1.24.0; fixed in 1.24.1\n- timber/timber (Packagist): affected from 1.24.0; fixed in 1.24.1\n- timber/timber (Packagist): affected from 2.0.0; fixed in 2.1.0\n- timber/timber (Packagist): affected from 2.0.0; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29800/ (Markdown: https://insights.sbomify.com/CVE-2024-29800/index.md)","id":"CVE-2024-29800","markdown":"https://insights.sbomify.com/CVE-2024-29800/index.md","name":"CVE-2024-29800","record":{"aliases":["GHSA-6363-v5m4-fvq3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"An attacker can execute arbitrary code by exploiting a deserialization vulnerability in the Timber WordPress plugin.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of Untrusted Data vulnerability in Timber Team \u0026 Contributors Timber.This issue affects Timber: from n/a through 1.23.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Timber plugin \u003c= 1.23.0 - Deserialization of untrusted data vulnerability","id":"CVE-2024-29800","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":6,"n_references":1,"next":{"headline":"WordPress Fullscreen Galleria plugin \u003c= 1.6.11 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29801"},"packages":[{"ecosystem":"Packagist","fixed":["1.23.1"],"introduced":["0.16.6"],"last_affected":[],"package":"timber/timber","purl":null,"source":"GHSA-6363-v5m4-fvq3"},{"ecosystem":"Packagist","fixed":["1.23.1"],"introduced":["0.16.6"],"last_affected":[],"package":"timber/timber","purl":"pkg:composer/timber/timber","source":"GHSA-6363-v5m4-fvq3"},{"ecosystem":"Packagist","fixed":["1.24.1"],"introduced":["1.24.0"],"last_affected":[],"package":"timber/timber","purl":null,"source":"GHSA-6363-v5m4-fvq3"},{"ecosystem":"Packagist","fixed":["1.24.1"],"introduced":["1.24.0"],"last_affected":[],"package":"timber/timber","purl":"pkg:composer/timber/timber","source":"GHSA-6363-v5m4-fvq3"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"timber/timber","purl":null,"source":"GHSA-6363-v5m4-fvq3"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["2.0.0"],"last_affected":[],"package":"timber/timber","purl":"pkg:composer/timber/timber","source":"GHSA-6363-v5m4-fvq3"}],"prev":{"headline":"WordPress WP Fast Total Search plugin \u003c= 1.59.211 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29799"},"products":["Timber"],"published":"2024-05-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Timber Team \u0026 Contributors"]},"summary":"An attacker can execute arbitrary code by exploiting a deserialization vulnerability in the Timber WordPress plugin.","url":"https://insights.sbomify.com/CVE-2024-29800/"}