# CVE-2024-29800: WordPress Timber plugin <= 1.23.0 - Deserialization of untrusted data vulnerability

> An attacker can execute arbitrary code by exploiting a deserialization vulnerability in the Timber WordPress plugin.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-6363-v5m4-fvq3

## What is CVE-2024-29800?

CVE-2024-29800 is a high-severity unsafe deserialization vulnerability in Timber, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Timber Team & Contributors Timber.This issue affects Timber: from n/a through 1.23.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-29800?

6 open source packages ship an affected version, including timber/timber.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `timber/timber` | Packagist | From 0.16.6 | 1.23.1 |
| `timber/timber` | Packagist | From 0.16.6 | 1.23.1 |
| `timber/timber` | Packagist | From 1.24.0 | 1.24.1 |
| `timber/timber` | Packagist | From 1.24.0 | 1.24.1 |
| `timber/timber` | Packagist | From 2.0.0 | 2.1.0 |
| `timber/timber` | Packagist | From 2.0.0 | 2.1.0 |

## How do I fix CVE-2024-29800?

Upgrade timber/timber to a fixed version for your release line: 1.23.1, 1.24.1 or 2.1.0.

## Is CVE-2024-29800 being exploited?

There is no known exploitation of CVE-2024-29800 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29800 and fix it if it is affected.

What it is: CVE-2024-29800 is a high-severity unsafe deserialization vulnerability in Timber, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29800 in the wild and no public exploit code.

Affected packages and fixed versions:
- timber/timber (Packagist): affected from 0.16.6; fixed in 1.23.1
- timber/timber (Packagist): affected from 0.16.6; fixed in 1.23.1
- timber/timber (Packagist): affected from 1.24.0; fixed in 1.24.1
- timber/timber (Packagist): affected from 1.24.0; fixed in 1.24.1
- timber/timber (Packagist): affected from 2.0.0; fixed in 2.1.0
- timber/timber (Packagist): affected from 2.0.0; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29800/ (Markdown: https://insights.sbomify.com/CVE-2024-29800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29800
- OSV: https://osv.dev/vulnerability/CVE-2024-29800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29800/
Summaries are generated and may contain mistakes; the official description above is the record.
