CVE-2024-29834 Apache Pulsar: Improper Authorization For Namespace and Topic Management Endpoints

Medium 6.4 Published Updated

Authenticated users can perform unauthorized management operations and modify namespace properties due to improper authorization checks.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29834?

CVE-2024-29834 is a medium-severity missing authorization vulnerability in Apache Pulsar, published on 2 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

This vulnerability allows authenticated users with produce or consume permissions to perform unauthorized operations on partitioned topics, such as unloading topics and triggering compaction. These management operations should be restricted to users with the tenant admin role or superuser role. An authenticated user with produce permission can create subscriptions and update subscription properties on partitioned topics, even though this should be limited to users with consume permissions. This impact analysis assumes that Pulsar has been configured with the default authorization provider. For custom authorization providers, the impact could be slightly different. Additionally, the vulnerability allows an authenticated user to read, create, modify, and delete namespace properties in any namespace in any tenant. In Pulsar, namespace properties are reserved for user provided metadata about the namespace.

This issue affects Apache Pulsar versions from 2.7.1 to 2.10.6, from 2.11.0 to 2.11.4, from 3.0.0 to 3.0.3, from 3.1.0 to 3.1.3, and from 3.2.0 to 3.2.1.

3.0 Apache Pulsar users should upgrade to at least 3.0.4. 3.1 and 3.2 Apache Pulsar users should upgrade to at least 3.2.2.

Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Weakness: CWE-863

Which versions are affected by CVE-2024-29834?

10 open source packages ship an affected version, including org.apache.pulsar:pulsar-broker. It affects 1 product.

PackageAffectedFixed in
org.apache.pulsar:pulsar-broker MavenFrom 2.11.0 to 2.11.4None
org.apache.pulsar:pulsar-broker MavenFrom 2.11.0 to 2.11.4None
org.apache.pulsar:pulsar-broker MavenFrom 2.7.1 to 2.10.6None
org.apache.pulsar:pulsar-broker MavenFrom 2.7.1 to 2.10.6None
org.apache.pulsar:pulsar-broker MavenFrom 3.0.03.0.4
org.apache.pulsar:pulsar-broker MavenFrom 3.0.03.0.4
4 more packages
org.apache.pulsar:pulsar-broker MavenFrom 3.1.0 to 3.1.3None
org.apache.pulsar:pulsar-broker MavenFrom 3.1.0 to 3.1.3None
org.apache.pulsar:pulsar-broker MavenFrom 3.2.03.2.2
org.apache.pulsar:pulsar-broker MavenFrom 3.2.03.2.2

Products include Apache Pulsar.

How do I fix CVE-2024-29834?

Upgrade org.apache.pulsar:pulsar-broker to a fixed version for your release line: 3.0.4 or 3.2.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-29834 being exploited?

There is no known exploitation of CVE-2024-29834 in the wild and no public exploit code.

Sources

Also known as GHSA-7mg2-6c6v-342r.

Is CVE-2024-29834 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free