# CVE-2024-29868: Apache StreamPipes: Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) in Recovery Token Generation

> Attackers can guess weak recovery tokens to take over user accounts in Apache StreamPipes due to insecure random number generation.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jun 2024
- **Updated:** 13 Sep 2024
- **Also known as:** GHSA-cf3q-vg8w-mw84

## What is CVE-2024-29868?

CVE-2024-29868 is a critical vulnerability in Apache StreamPipes, published on 24 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG) vulnerability in Apache StreamPipes user self-registration and password recovery mechanism.
This allows an attacker to guess the recovery token in a reasonable time and thereby to take over the attacked user's account.
This issue affects Apache StreamPipes: from 0.69.0 through 0.93.0.

Users are recommended to upgrade to version 0.95.0, which fixes the issue.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG))

## Which versions are affected by CVE-2024-29868?

2 open source packages ship an affected version, including org.apache.streampipes:streampipes-resource-management. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.streampipes:streampipes-resource-management` | Maven | From 0.69.0 | 0.95.0 |
| `org.apache.streampipes:streampipes-resource-management` | Maven | From 0.69.0 | 0.95.0 |

Products: Apache Streampipes.

## How do I fix CVE-2024-29868?

Upgrade org.apache.streampipes:streampipes-resource-management to 0.95.0 or later.

## Is CVE-2024-29868 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29868 exists.

Public exploit code:

- Proof of concept of CVE-2024-29868 affecting Apache StreamPipes from 0.69.0 through 0.93.0 (github_poc): https://github.com/DEVisions/CVE-2024-29868
- Apache StreamPipes <= 0.93.0 - Use of Cryptographically Weak PRNG in Recovery Token Generation (nuclei): http/cves/2024/CVE-2024-29868.yaml

## Other vulnerabilities in Apache StreamPipes

- [CVE-2023-31469](https://insights.sbomify.com/CVE-2023-31469/): Apache StreamPipes: Privilege escalation through non-admin user (high 8.8)
- [CVE-2025-47411](https://insights.sbomify.com/CVE-2025-47411/): Apache StreamPipes: Leverage of User ID for Privilege Escalation (high 8.1)
- [CVE-2024-31979](https://insights.sbomify.com/CVE-2024-31979/): Apache StreamPipes: Possibility of SSRF in pipeline element installation process (high 7.5)
- [CVE-2024-24778](https://insights.sbomify.com/CVE-2024-24778/): Apache StreamPipes: Resources Permission Escalation (medium 6.5)
- [CVE-2024-31411](https://insights.sbomify.com/CVE-2024-31411/): Apache StreamPipes: Potential remote code execution (RCE) via file upload (medium 6.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29868 and fix it if it is affected.

What it is: CVE-2024-29868 is a critical vulnerability in Apache StreamPipes, published on 24 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29868 exists.

Affected packages and fixed versions:
- org.apache.streampipes:streampipes-resource-management (Maven): affected from 0.69.0; fixed in 0.95.0
- org.apache.streampipes:streampipes-resource-management (Maven): affected from 0.69.0; fixed in 0.95.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29868/ (Markdown: https://insights.sbomify.com/CVE-2024-29868/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29868
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29868
- OSV: https://osv.dev/vulnerability/CVE-2024-29868

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29868/
Summaries are generated and may contain mistakes; the official description above is the record.
