# CVE-2024-29869: Apache Hive: Credentials file created with non restrictive permissions

> An attacker with local access can read sensitive credentials from a Hive temporary file due to insecure default permissions.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2025
- **Updated:** 29 Jan 2025
- **Also known as:** CLEANSTART-2026-GO41173, CLSA-2026-1780966326, ECHO-ea2f-35d1-c90a, GHSA-c476-j253-5rgq, MINI-4mr6-fgqf-phjq, MINI-7xh2-g9h2-2xhw, MINI-fw9q-c9c7-g94x

## What is CVE-2024-29869?

CVE-2024-29869 is a medium-severity vulnerability in Apache Hive, published on 28 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Hive creates a credentials file to a temporary directory in the file system with permissions 644 by default when the file permissions are not set explicitly. Any unauthorized user having access to the directory can read the sensitive information written into this file. Users are recommended to upgrade to version 4.0.1, which fixes this issue.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-29869?

2 open source packages ship an affected version, including org.apache.hive:hive-exec. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hive:hive-exec` | Maven | All versions | 4.0.1 |
| `org.apache.hive:hive-exec` | Maven | All versions | 4.0.1 |

Products: Apache Hive.

## How do I fix CVE-2024-29869?

Upgrade org.apache.hive:hive-exec to 4.0.1 or later.

## Is CVE-2024-29869 being exploited?

There is no known exploitation of CVE-2024-29869 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hive

- [CVE-2026-49845](https://insights.sbomify.com/CVE-2026-49845/): Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths (critical 9.8)
- [CVE-2018-21234](https://insights.sbomify.com/CVE-2018-21234/): Deserialization of Untrusted Data in Jodd (critical 9.8)
- [CVE-2026-55976](https://insights.sbomify.com/CVE-2026-55976/): Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url (critical 9.1)
- [CVE-2018-1282](https://insights.sbomify.com/CVE-2018-1282/): SQL Injection in hive-jdbc (critical 9.1)
- [CVE-2022-41137](https://insights.sbomify.com/CVE-2022-41137/): Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29869 and fix it if it is affected.

What it is: CVE-2024-29869 is a medium-severity vulnerability in Apache Hive, published on 28 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29869 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 4.0.1
- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29869/ (Markdown: https://insights.sbomify.com/CVE-2024-29869/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29869
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29869
- OSV: https://osv.dev/vulnerability/CVE-2024-29869

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29869/
Summaries are generated and may contain mistakes; the official description above is the record.
