{"answers":{"affected":"2 open source packages ship an affected version, including silverstripe/reports. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29885 in the wild and no public exploit code.","fix":"Upgrade silverstripe/reports to 5.2.3 or later.","what":"CVE-2024-29885 is a medium-severity missing authorization vulnerability in silverstripe-reports, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29885 and fix it if it is affected.\n\nWhat it is: CVE-2024-29885 is a medium-severity missing authorization vulnerability in silverstripe-reports, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-29885 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- silverstripe/reports (Packagist): affected all versions; fixed in 5.2.3\n- silverstripe/reports (Packagist): affected all versions; fixed in 5.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29885/ (Markdown: https://insights.sbomify.com/CVE-2024-29885/index.md)","id":"CVE-2024-29885","markdown":"https://insights.sbomify.com/CVE-2024-29885/index.md","name":"CVE-2024-29885","record":{"aliases":["GHSA-89q6-98xx-4ffw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Silverstripe reports module","requires_auth":"low_privilege","summary":"Attackers with admin access can view restricted reports via direct URLs despite permission checks, requiring an upgrade to the Silverstripe reports module.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"reports","vendor":"silverstripe"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"silverstripe/reports is an API for creating backend reports in the Silverstripe Framework. In affected versions reports can be accessed by their direct URL by any user who has access to view the reports admin section, even if the `canView()` method for that report returns `false`. This issue has been addressed in version 5.2.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reports are still accessible even when `canView()` returns false in silverstripe/reports","id":"CVE-2024-29885","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Improved security for stored password hashes","id":"CVE-2024-29886"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.3"],"introduced":["0"],"last_affected":[],"package":"silverstripe/reports","purl":null,"source":"GHSA-89q6-98xx-4ffw"},{"ecosystem":"Packagist","fixed":["5.2.3"],"introduced":["0"],"last_affected":[],"package":"silverstripe/reports","purl":"pkg:composer/silverstripe/reports","source":"GHSA-89q6-98xx-4ffw"}],"prev":{"headline":"CreateWiki's wiki request suppression ignores the suppression settings set by the suppressor","id":"CVE-2024-29883"},"products":["silverstripe-reports"],"published":"2024-07-17","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["silverstripe"]},"summary":"Attackers with admin access can view restricted reports via direct URLs despite permission checks, requiring an upgrade to the Silverstripe reports module.","url":"https://insights.sbomify.com/CVE-2024-29885/"}