# CVE-2024-29885: Reports are still accessible even when `canView()` returns false in silverstripe/reports

> Attackers with admin access can view restricted reports via direct URLs despite permission checks, requiring an upgrade to the Silverstripe reports module.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-89q6-98xx-4ffw

## What is CVE-2024-29885?

CVE-2024-29885 is a medium-severity missing authorization vulnerability in silverstripe-reports, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

silverstripe/reports is an API for creating backend reports in the Silverstripe Framework. In affected versions reports can be accessed by their direct URL by any user who has access to view the reports admin section, even if the `canView()` method for that report returns `false`. This issue has been addressed in version 5.2.3. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-29885?

2 open source packages ship an affected version, including silverstripe/reports. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/reports` | Packagist | All versions | 5.2.3 |
| `silverstripe/reports` | Packagist | All versions | 5.2.3 |

Products: Silverstripe Reports.

## How do I fix CVE-2024-29885?

Upgrade silverstripe/reports to 5.2.3 or later.

## Is CVE-2024-29885 being exploited?

There is no known exploitation of CVE-2024-29885 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29885 and fix it if it is affected.

What it is: CVE-2024-29885 is a medium-severity missing authorization vulnerability in silverstripe-reports, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29885 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/reports (Packagist): affected all versions; fixed in 5.2.3
- silverstripe/reports (Packagist): affected all versions; fixed in 5.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29885/ (Markdown: https://insights.sbomify.com/CVE-2024-29885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29885
- OSV: https://osv.dev/vulnerability/CVE-2024-29885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29885/
Summaries are generated and may contain mistakes; the official description above is the record.
