# CVE-2024-29886: Improved security for stored password hashes

> Weak password hashing in Serverpod allows attackers to recover passwords via rainbow tables if the database is compromised.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r75m-26cq-mjxc

## What is CVE-2024-29886?

CVE-2024-29886 is a medium-severity vulnerability in serverpod, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Serverpod is an app and web server, built for the Flutter and Dart ecosystem. An issue was identified with the old password hash algorithm that made it susceptible to rainbow attacks if the database was compromised. This vulnerability is fixed by 1.2.6.

Weakness: CWE-916 (Use of Password Hash With Insufficient Computational Effort)

## Which versions are affected by CVE-2024-29886?

2 open source packages ship an affected version, including serverpod_auth_server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `serverpod_auth_server` | Pub | All versions | 1.2.6 |
| `serverpod_auth_server` | Pub | All versions | 1.2.6 |

Products: Serverpod Serverpod.

## How do I fix CVE-2024-29886?

Upgrade serverpod_auth_server to 1.2.6 or later.

## Is CVE-2024-29886 being exploited?

There is no known exploitation of CVE-2024-29886 in the wild and no public exploit code.

## Other vulnerabilities in serverpod

- [CVE-2024-29887](https://insights.sbomify.com/CVE-2024-29887/): Serverpod client accepts any certificate (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29886 and fix it if it is affected.

What it is: CVE-2024-29886 is a medium-severity vulnerability in serverpod, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29886 in the wild and no public exploit code.

Affected packages and fixed versions:
- serverpod_auth_server (Pub): affected all versions; fixed in 1.2.6
- serverpod_auth_server (Pub): affected all versions; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29886/ (Markdown: https://insights.sbomify.com/CVE-2024-29886/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29886
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29886
- OSV: https://osv.dev/vulnerability/CVE-2024-29886

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29886/
Summaries are generated and may contain mistakes; the official description above is the record.
