{"answers":{"affected":"2 open source packages ship an affected version, including serverpod_client. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29887 exists.","fix":"Upgrade serverpod_client to 1.2.6 or later.","what":"CVE-2024-29887 is a high-severity vulnerability in serverpod, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29887 and fix it if it is affected.\n\nWhat it is: CVE-2024-29887 is a high-severity vulnerability in serverpod, published on 27 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29887 exists.\n\nAffected packages and fixed versions:\n- serverpod_client (Pub): affected all versions; fixed in 1.2.6\n- serverpod_client (Pub): affected all versions; fixed in 1.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29887/ (Markdown: https://insights.sbomify.com/CVE-2024-29887/index.md)","id":"CVE-2024-29887","markdown":"https://insights.sbomify.com/CVE-2024-29887/index.md","name":"CVE-2024-29887","record":{"aliases":["GHSA-h6x7-r5rg-x5fw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Serverpod client library","requires_auth":"none","summary":"The Serverpod client library fails to validate TLS certificates, allowing attackers to perform man-in-the-middle attacks and intercept or modify encrypted traffic.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"serverpod","vendor":"serverpod"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the `serverpod_client` package. Making them susceptible to a man in the middle attack against encrypted traffic between the client device and the server. An attacker would need to be able to intercept the traffic and highjack the connection to the server for this vulnerability to be used. Upgrading to version `1.2.6` resolves this issue.","ecosystems":["Pub"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Serverpod client accepts any certificate","id":"CVE-2024-29887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Saleor vulnerable to customers addresses leak when using Warehouse as a `Pickup: Local stock only` delivery method","id":"CVE-2024-29888"},"packages":[{"ecosystem":"Pub","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"serverpod_client","purl":null,"source":"GHSA-h6x7-r5rg-x5fw"},{"ecosystem":"Pub","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"serverpod_client","purl":"pkg:pub/serverpod_client","source":"GHSA-h6x7-r5rg-x5fw"}],"prev":{"headline":"Improved security for stored password hashes","id":"CVE-2024-29886"},"products":["serverpod"],"published":"2024-03-27","related":[{"cvss_score":5.3,"headline":"Improved security for stored password hashes","id":"CVE-2024-29886","kev_date_added":null,"published":"2024-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-27","vendors":["serverpod"]},"summary":"The Serverpod client library fails to validate TLS certificates, allowing attackers to perform man-in-the-middle attacks and intercept or modify encrypted traffic.","url":"https://insights.sbomify.com/CVE-2024-29887/"}