CVE-2024-29900 @electron/packager's build process memory potentially leaked into final executable

High 7.5 Published Updated

Electron Packager may leak sensitive Node.js heap memory into final executables, exposing secrets to attackers who obtain the distributed application.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29900?

CVE-2024-29900 is a high-severity vulnerability in electron packager, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Electron Packager bundles Electron-based application source code with a renamed Electron executable and supporting files into folders ready for distribution. A random segment of ~1-10kb of Node.js heap memory allocated either side of a known buffer will be leaked into the final executable. This memory _could_ contain sensitive information such as environment variables, secrets files, etc. This issue is patched in 18.3.1.

Weakness: CWE-402

Which versions are affected by CVE-2024-29900?

2 open source packages ship an affected version, including @electron/packager. It affects 1 product.

PackageAffectedFixed in
@electron/packager npmFrom 18.3.018.3.1
@electron/packager npmFrom 18.3.018.3.1

Products include Openjsf Packager.

How do I fix CVE-2024-29900?

Upgrade @electron/packager to 18.3.1 or later.

Is CVE-2024-29900 being exploited?

There is no known exploitation of CVE-2024-29900 in the wild and no public exploit code.

Sources

Also known as GHSA-34h3-8mw4-qw57.

Is CVE-2024-29900 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free