# CVE-2024-29900: @electron/packager's build process memory potentially leaked into final executable

> Electron Packager may leak sensitive Node.js heap memory into final executables, exposing secrets to attackers who obtain the distributed application.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-34h3-8mw4-qw57

## What is CVE-2024-29900?

CVE-2024-29900 is a high-severity vulnerability in electron packager, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Electron Packager bundles Electron-based application source code with a renamed Electron executable and supporting files into folders ready for distribution. A random segment of ~1-10kb of Node.js heap memory allocated either side of a known buffer will be leaked into the final executable. This memory _could_ contain sensitive information such as environment variables, secrets files, etc. This issue is patched in 18.3.1.

Weakness: CWE-402 (Transmission of Private Resources into a New Sphere)

## Which versions are affected by CVE-2024-29900?

2 open source packages ship an affected version, including @electron/packager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@electron/packager` | npm | From 18.3.0 | 18.3.1 |
| `@electron/packager` | npm | From 18.3.0 | 18.3.1 |

Products: Openjsf Packager.

## How do I fix CVE-2024-29900?

Upgrade @electron/packager to 18.3.1 or later.

## Is CVE-2024-29900 being exploited?

There is no known exploitation of CVE-2024-29900 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29900 and fix it if it is affected.

What it is: CVE-2024-29900 is a high-severity vulnerability in electron packager, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29900 in the wild and no public exploit code.

Affected packages and fixed versions:
- @electron/packager (npm): affected from 18.3.0; fixed in 18.3.1
- @electron/packager (npm): affected from 18.3.0; fixed in 18.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29900/ (Markdown: https://insights.sbomify.com/CVE-2024-29900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29900
- OSV: https://osv.dev/vulnerability/CVE-2024-29900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29900/
Summaries are generated and may contain mistakes; the official description above is the record.
