{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29904 exists.","fix":"Upgrade codeigniter4/framework to 4.4.7 or later.","what":"CVE-2024-29904 is a high-severity denial of service vulnerability in CodeIgniter4, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-29904 and fix it if it is affected.\n\nWhat it is: CVE-2024-29904 is a high-severity denial of service vulnerability in CodeIgniter4, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29904 exists.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.7\n- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29904/ (Markdown: https://insights.sbomify.com/CVE-2024-29904/index.md)","id":"CVE-2024-29904","markdown":"https://insights.sbomify.com/CVE-2024-29904/index.md","name":"CVE-2024-29904","record":{"aliases":["GHSA-39fp-mqmm-gxj6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP web framework","requires_auth":"none","summary":"An attacker can cause a denial of service by consuming excessive server memory through the Language class in CodeIgniter4.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"CodeIgniter4 Language class DoS Vulnerability","id":"CVE-2024-29904","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"DIRAC: Unauthorized users can read proxy contents during generation","id":"CVE-2024-29905"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.7"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-39fp-mqmm-gxj6"},{"ecosystem":"Packagist","fixed":["4.4.7"],"introduced":["0"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-39fp-mqmm-gxj6"}],"prev":{"headline":"Cosign vulnerable to machine-wide denial of service via malicious artifacts","id":"CVE-2024-29903"},"products":["CodeIgniter4"],"published":"2024-03-29","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["codeigniter4"]},"summary":"An attacker can cause a denial of service by consuming excessive server memory through the Language class in CodeIgniter4.","url":"https://insights.sbomify.com/CVE-2024-29904/"}