# CVE-2024-29904: CodeIgniter4 Language class DoS Vulnerability

> An attacker can cause a denial of service by consuming excessive server memory through the Language class in CodeIgniter4.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Mar 2024
- **Updated:** 21 Aug 2024
- **Also known as:** GHSA-39fp-mqmm-gxj6

## What is CVE-2024-29904?

CVE-2024-29904 is a high-severity denial of service vulnerability in CodeIgniter4, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework A vulnerability was found in the Language class that allowed DoS attacks. This vulnerability can be exploited by an attacker to consume a large amount of memory on the server. Upgrade to v4.4.7 or later.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2024-29904?

2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.4.7 |
| `codeigniter4/framework` | Packagist | All versions | 4.4.7 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2024-29904?

Upgrade codeigniter4/framework to 4.4.7 or later.

## Is CVE-2024-29904 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29904 exists.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29904 and fix it if it is affected.

What it is: CVE-2024-29904 is a high-severity denial of service vulnerability in CodeIgniter4, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-29904 exists.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.7
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29904/ (Markdown: https://insights.sbomify.com/CVE-2024-29904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29904
- OSV: https://osv.dev/vulnerability/CVE-2024-29904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29904/
Summaries are generated and may contain mistakes; the official description above is the record.
