{"answers":{"affected":"3 open source packages ship an affected version, including dirac and DIRAC. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-29905 in the wild and no public exploit code.","fix":"Upgrade dirac to 8.0.41 or later.","what":"CVE-2024-29905 is a high-severity vulnerability in DIRACGrid DIRAC, published on 9 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-29905 and fix it if it is affected.\n\nWhat it is: CVE-2024-29905 is a high-severity vulnerability in DIRACGrid DIRAC, published on 9 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-29905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dirac (PyPI): affected all versions; fixed in 8.0.41\n- dirac (PyPI): affected all versions; fixed in 8.0.41\n- DIRAC (PyPI): affected all versions; fixed in 8.0.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-29905/ (Markdown: https://insights.sbomify.com/CVE-2024-29905/index.md)","id":"CVE-2024-29905","markdown":"https://insights.sbomify.com/CVE-2024-29905/index.md","name":"CVE-2024-29905","record":{"aliases":["GHSA-v6f3-gh5h-mqwx","PYSEC-2026-1295"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"DIRAC distributed computing","requires_auth":"low_privilege","summary":"Unauthorized local users can read proxy contents during generation, allowing them to impersonate the victim and perform actions with the original proxy.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dirac","vendor":"diracgrid"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-668","name":"Exposure of Resource to Wrong Sphere"}],"description":"DIRAC is an interware, meaning a software framework for distributed computing. Prior to version 8.0.41, during the proxy generation process (e.g., when using `dirac-proxy-init`), it is possible for unauthorized users on the same machine to gain read access to the proxy. This allows the user to then perform any action that is possible with the original proxy. This vulnerability only exists for a short period of time (sub-millsecond) during the generation process. Version 8.0.41 contains a patch for the issue. As a workaround, setting the `X509_USER_PROXY` environment variable to a path that is inside a directory that is only readable to the current user avoids the potential risk. After the file has been written, it can be safely copied to the standard location (`/tmp/x509up_uNNNN`).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DIRAC: Unauthorized users can read proxy contents during generation","id":"CVE-2024-29905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"information_disclosure","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"WordPress MDTF – Meta Data and Taxonomies Filter plugin \u003c= 1.3.2 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-29906"},"packages":[{"ecosystem":"PyPI","fixed":["8.0.41"],"introduced":["0"],"last_affected":[],"package":"DIRAC","purl":null,"source":"GHSA-v6f3-gh5h-mqwx"},{"ecosystem":"PyPI","fixed":["8.0.41"],"introduced":["0"],"last_affected":[],"package":"dirac","purl":"pkg:pypi/dirac","source":"GHSA-v6f3-gh5h-mqwx"},{"ecosystem":"PyPI","fixed":["8.0.41"],"introduced":["0"],"last_affected":[],"package":"dirac","purl":"pkg:pypi/dirac","source":"PYSEC-2026-1295"}],"prev":{"headline":"CodeIgniter4 Language class DoS Vulnerability","id":"CVE-2024-29904"},"products":["DIRAC"],"published":"2024-04-09","related":[{"cvss_score":9.1,"headline":"TokenManager not checking permissions on cached tokens in DIRAC","id":"CVE-2024-24825","kev_date_added":null,"published":"2024-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["DIRACGrid"]},"summary":"Unauthorized local users can read proxy contents during generation, allowing them to impersonate the victim and perform actions with the original proxy.","url":"https://insights.sbomify.com/CVE-2024-29905/"}