# CVE-2024-29905: DIRAC: Unauthorized users can read proxy contents during generation

> Unauthorized local users can read proxy contents during generation, allowing them to impersonate the victim and perform actions with the original proxy.

- **Severity:** High 8.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-v6f3-gh5h-mqwx, PYSEC-2026-1295

## What is CVE-2024-29905?

CVE-2024-29905 is a high-severity vulnerability in DIRACGrid DIRAC, published on 9 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

DIRAC is an interware, meaning a software framework for distributed computing. Prior to version 8.0.41, during the proxy generation process (e.g., when using `dirac-proxy-init`), it is possible for unauthorized users on the same machine to gain read access to the proxy. This allows the user to then perform any action that is possible with the original proxy. This vulnerability only exists for a short period of time (sub-millsecond) during the generation process. Version 8.0.41 contains a patch for the issue. As a workaround, setting the `X509_USER_PROXY` environment variable to a path that is inside a directory that is only readable to the current user avoids the potential risk. After the file has been written, it can be safely copied to the standard location (`/tmp/x509up_uNNNN`).

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2024-29905?

3 open source packages ship an affected version, including dirac and DIRAC. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dirac` | PyPI | All versions | 8.0.41 |
| `dirac` | PyPI | All versions | 8.0.41 |
| `DIRAC` | PyPI | All versions | 8.0.41 |

Products: Diracgrid Dirac.

## How do I fix CVE-2024-29905?

Upgrade dirac to 8.0.41 or later.

## Is CVE-2024-29905 being exploited?

There is no known exploitation of CVE-2024-29905 in the wild and no public exploit code.

## Other vulnerabilities in DIRACGrid DIRAC

- [CVE-2024-24825](https://insights.sbomify.com/CVE-2024-24825/): TokenManager not checking permissions on cached tokens in DIRAC (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29905 and fix it if it is affected.

What it is: CVE-2024-29905 is a high-severity vulnerability in DIRACGrid DIRAC, published on 9 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-29905 in the wild and no public exploit code.

Affected packages and fixed versions:
- dirac (PyPI): affected all versions; fixed in 8.0.41
- dirac (PyPI): affected all versions; fixed in 8.0.41
- DIRAC (PyPI): affected all versions; fixed in 8.0.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29905/ (Markdown: https://insights.sbomify.com/CVE-2024-29905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29905
- OSV: https://osv.dev/vulnerability/CVE-2024-29905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29905/
Summaries are generated and may contain mistakes; the official description above is the record.
