CVE-2024-29977 Malicious remote can create arbitrary reactions on arbitrary posts

Low 2.7 Published Updated

A malicious remote user can create arbitrary reactions on posts in shared channels, requiring shared channels to be enabled.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-29977?

CVE-2024-29977 is a low-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly validate synced reactions, when shared channels are enabled, which allows a malicious remote to create arbitrary reactions on arbitrary posts

Weakness: CWE-284

Which versions are affected by CVE-2024-29977?

8 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.7
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.1
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.7+incompatible, 9.9.1+incompatible
2 more packages
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost.

How do I fix CVE-2024-29977?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7 or 9.9.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-29977 being exploited?

There is no known exploitation of CVE-2024-29977 in the wild and no public exploit code.

All Mattermost Mattermost vulnerabilities

Sources

Also known as GHSA-jq3g-xqpx-37x3, GO-2024-3030.

Is CVE-2024-29977 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free