# CVE-2024-29977: Malicious remote can create arbitrary reactions on arbitrary posts

> A malicious remote user can create arbitrary reactions on posts in shared channels, requiring shared channels to be enabled.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-jq3g-xqpx-37x3, GO-2024-3030

## What is CVE-2024-29977?

CVE-2024-29977 is a low-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6 fail to properly validate synced reactions, when shared channels are enabled, which allows a malicious remote to create arbitrary reactions on arbitrary posts

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-29977?

8 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.7 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.5.0 | 9.5.7 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.9.0 | 9.9.1 |
| `github.com/mattermost/mattermost-server` | Go | From 9.5.0+incompatible | 9.5.7+incompatible, 9.9.1+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost.

## How do I fix CVE-2024-29977?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.5.7 or 9.9.1.

## Is CVE-2024-29977 being exploited?

There is no known exploitation of CVE-2024-29977 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost

- [CVE-2019-20851](https://insights.sbomify.com/CVE-2019-20851/): Path traversal in n/a (critical 9.1)
- [CVE-2024-39274](https://insights.sbomify.com/CVE-2024-39274/): Malicious remote can add users to arbitrary teams and channels (high 8.7)
- [CVE-2024-39777](https://insights.sbomify.com/CVE-2024-39777/): Malicious remote can invite itself to an arbitrary local channel (high 8.7)
- [CVE-2024-39830](https://insights.sbomify.com/CVE-2024-39830/): Timing attack during remote cluster token comparison when shared channels are enabled (high 8.1)
- [CVE-2023-3615](https://insights.sbomify.com/CVE-2023-3615/): Lack of server certificate validation in websockets connection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-29977 and fix it if it is affected.

What it is: CVE-2024-29977 is a low-severity missing authorization vulnerability in Mattermost Mattermost, published on 1 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-29977 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.7
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.5.0; fixed in 9.5.7
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.9.0; fixed in 9.9.1
- github.com/mattermost/mattermost-server (Go): affected from 9.5.0+incompatible; fixed in 9.5.7+incompatible, 9.9.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-29977/ (Markdown: https://insights.sbomify.com/CVE-2024-29977/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-29977
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-29977
- OSV: https://osv.dev/vulnerability/CVE-2024-29977

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-29977/
Summaries are generated and may contain mistakes; the official description above is the record.
