CVE-2024-3013 Teledyne FLIR AX8 User Registration test_login.php improper authorization

Medium 5.3 Published Updated

Remote attackers can bypass authorization checks in the user registration component of Teledyne FLIR AX8 devices to perform unauthorized actions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-3013?

CVE-2024-3013 is a medium-severity missing authorization vulnerability in Teledyne FLIR AX8, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A flaw has been found in Teledyne FLIR AX8 up to 1.46.16. The impacted element is an unknown function of the file /tools/test_login.php?action=register of the component User Registration. Executing manipulation can lead to improper authorization. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version 1.49.16 is sufficient to resolve this issue. Upgrading the affected component is recommended. The vendor points out: "FLIR AX8 internal web site has been refactored to be able to handle the reported vulnerabilities."

Weakness: CWE-285, CWE-266

Which versions are affected by CVE-2024-3013?

It affects 1 product.

Products include Flir Flir Ax8 Firmware.

How do I fix CVE-2024-3013?

No fix has been published for CVE-2024-3013 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-3013 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3013 exists.

Sources

Also known as GHSA-mgm7-v27r-x559.

Is CVE-2024-3013 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free