CVE-2024-30170 Denial of service in n/a
Attackers can exfiltrate data and cause denial of service via the REST API in PrivX access management software.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-30170?
CVE-2024-30170 is a high-severity denial of service vulnerability in n/a, published on 6 Aug 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
PrivX before 34.0 allows data exfiltration and denial of service via the REST API. This is fixed in minor versions 33.1, 32.3, 31.3, and later, and in major version 34.0 and later,
Weakness: CWE-400
Which versions are affected by CVE-2024-30170?
It affects 1 product.
Products include Ssh Privx.
How do I fix CVE-2024-30170?
No fix has been published for CVE-2024-30170 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-30170 being exploited?
There is no known exploitation of CVE-2024-30170 in the wild and no public exploit code.
Sources
Also known as GHSA-r7x6-6cmj-2972.