# CVE-2024-30241: SQL injection in ProfileGrid

> Contributors can exploit SQL injection in ProfileGrid to read or modify database contents, requiring plugin updates.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Mar 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-p546-g9xq-c75r

## What is CVE-2024-30241?

CVE-2024-30241 is a high-severity SQL injection vulnerability in Metagauss ProfileGrid, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Metagauss ProfileGrid.This issue affects ProfileGrid : from n/a through 5.7.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-30241?

It affects 1 product.


Products: Metagauss Profilegrid.

## How do I fix CVE-2024-30241?

No fix has been published for CVE-2024-30241 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-30241 being exploited?

There is no known exploitation of CVE-2024-30241 in the wild and no public exploit code.

## Other vulnerabilities in Metagauss ProfileGrid

- [CVE-2024-30490](https://insights.sbomify.com/CVE-2024-30490/): WordPress ProfileGrid plugin <= 5.7.8 - SQL Injection vulnerability (critical 9.3)
- [CVE-2025-0724](https://insights.sbomify.com/CVE-2025-0724/): ProfileGrid – User Profiles, Groups and Communities <= 5.9.4.5 - Authenticated (Subscriber+) PHP Object Injection (high 8.8)
- [CVE-2024-6411](https://insights.sbomify.com/CVE-2024-6411/): Privilege escalation in ProfileGrid – User Profiles, Groups and Communities (high 8.8)
- [CVE-2023-3713](https://insights.sbomify.com/CVE-2023-3713/): ProfileGrid <= 5.5.1 - Authenticated (Subscriber+) Arbitrary Option Update (high 8.8)
- [CVE-2023-0940](https://insights.sbomify.com/CVE-2023-0940/): ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30241 and fix it if it is affected.

What it is: CVE-2024-30241 is a high-severity SQL injection vulnerability in Metagauss ProfileGrid, published on 28 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-30241 in the wild and no public exploit code.

Affected product: Metagauss ProfileGrid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30241/ (Markdown: https://insights.sbomify.com/CVE-2024-30241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30241
- OSV: https://osv.dev/vulnerability/CVE-2024-30241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30241/
Summaries are generated and may contain mistakes; the official description above is the record.
