CVE-2024-30249 Cloudburst Network DoS in RakNet connection handling

High 8.6 Published Updated

Attackers can exploit Cloudburst Network to launch UDP amplification attacks or suspend host services, requiring library upgrades.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-30249?

CVE-2024-30249 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR1-20240330.101522-15` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to use Network as an amplification vector for a UDP denial of service attack against a third party or as an attempt to trigger service suspension of the host. All consumers of the library should upgrade to at least version `1.0.0.CR1-20240330.101522-15` to receive a fix. There are no known workarounds beyond updating the library.

Weakness: CWE-770

Which versions are affected by CVE-2024-30249?

How do I fix CVE-2024-30249?

No fix has been published for CVE-2024-30249 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-30249 being exploited?

There is no known exploitation of CVE-2024-30249 in the wild and no public exploit code.

Sources

Is CVE-2024-30249 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free