{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2024-30249 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-30249 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-30249 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-30249 and fix it if it is affected.\n\nWhat it is: CVE-2024-30249 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-30249 in the wild and no public exploit code.\n\nAffected product: CloudburstMC Network. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-30249/ (Markdown: https://insights.sbomify.com/CVE-2024-30249/index.md)","id":"CVE-2024-30249","markdown":"https://insights.sbomify.com/CVE-2024-30249/index.md","name":"CVE-2024-30249","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloudburst Network library","requires_auth":"none","summary":"Attackers can exploit Cloudburst Network to launch UDP amplification attacks or suspend host services, requiring library upgrades.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR1-20240330.101522-15` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to use Network as an amplification vector for a UDP denial of service attack against a third party or as an attempt to trigger service suspension of the host. All consumers of the library should upgrade to at least version `1.0.0.CR1-20240330.101522-15` to receive a fix. There are no known workarounds beyond updating the library.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cloudburst Network DoS in RakNet connection handling","id":"CVE-2024-30249","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":0,"n_references":1,"next":{"headline":"In Astro-Shield, setting a correct `integrity` attribute to injected code allows to bypass the allow-lists","id":"CVE-2024-30250"},"packages":[],"prev":{"headline":"Piccolo Admin's raw SVG loading may lead to complete data compromise from admin page","id":"CVE-2024-30248"},"products":["Network"],"published":"2024-04-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-21","vendors":["CloudburstMC"]},"summary":"Attackers can exploit Cloudburst Network to launch UDP amplification attacks or suspend host services, requiring library upgrades.","url":"https://insights.sbomify.com/CVE-2024-30249/"}