# CVE-2024-30249: Cloudburst Network DoS in RakNet connection handling

> Attackers can exploit Cloudburst Network to launch UDP amplification attacks or suspend host services, requiring library upgrades.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Apr 2024
- **Updated:** 21 Aug 2024

## What is CVE-2024-30249?

CVE-2024-30249 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloudburst Network provides network components used within Cloudburst projects. A vulnerability in versions prior to `1.0.0.CR1-20240330.101522-15` impacts publicly accessible software depending on the affected versions of Network and allows an attacker to use Network as an amplification vector for a UDP denial of service attack against a third party or as an attempt to trigger service suspension of the host. All consumers of the library should upgrade to at least version `1.0.0.CR1-20240330.101522-15` to receive a fix. There are no known workarounds beyond updating the library.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-30249?


## How do I fix CVE-2024-30249?

No fix has been published for CVE-2024-30249 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-30249 being exploited?

There is no known exploitation of CVE-2024-30249 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30249 and fix it if it is affected.

What it is: CVE-2024-30249 is a high-severity denial of service vulnerability in CloudburstMC Network, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-30249 in the wild and no public exploit code.

Affected product: CloudburstMC Network. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30249/ (Markdown: https://insights.sbomify.com/CVE-2024-30249/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30249
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30249
- OSV: https://osv.dev/vulnerability/CVE-2024-30249

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30249/
Summaries are generated and may contain mistakes; the official description above is the record.
