CVE-2024-30250 In Astro-Shield, setting a correct `integrity` attribute to injected code allows to bypass the allow-lists
Attackers can bypass Astro-Shield's allow-lists by injecting code with valid integrity attributes, tricking browsers into accepting malicious resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-30250?
CVE-2024-30250 is a high-severity vulnerability in kindspells astro-shield, published on 4 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Astro-Shield is an integration to enhance website security with SubResource Integrity hashes, Content-Security-Policy headers, and other techniques. Versions from 1.2.0 to 1.3.1 of Astro-Shield allow bypass to the allow-lists for cross-origin resources by introducing valid `integrity` attributes to the injected code. This implies that the injected SRI hash would be added to the generated CSP header, which would lead the browser to believe that the injected resource is legit. This vulnerability is patched in version 1.3.2.
Weakness: CWE-345
Which versions are affected by CVE-2024-30250?
2 open source packages ship an affected version, including @kindspells/astro-shield. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@kindspells/astro-shield npm | From 1.2.0 | 1.3.2 |
@kindspells/astro-shield npm | From 1.2.0 | 1.3.2 |
Products include Kindspells Astro-Shield.
How do I fix CVE-2024-30250?
Upgrade @kindspells/astro-shield to 1.3.2 or later.
Is CVE-2024-30250 being exploited?
There is no known exploitation of CVE-2024-30250 in the wild and no public exploit code.
Other vulnerabilities in kindspells astro-shield
Sources
Also known as GHSA-c4gr-q97g-ppwc.