# CVE-2024-30257: 1Panel's password verification is suspected to have a timing attack vulnerability

> Attackers can exploit timing differences in password verification to bypass authentication and gain unauthorized access to the 1Panel management interface.

- **Severity:** Low 3.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6m9h-2pr2-9j8f, GO-2024-2734

## What is CVE-2024-30257?

CVE-2024-30257 is a low-severity vulnerability in 1Panel-dev 1Panel, published on 18 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

1Panel is an open source Linux server operation and maintenance management panel. The password verification in the source code uses the != symbol instead hmac.Equal. This may lead to a timing attack vulnerability. This vulnerability is fixed in 1.10.3-lts.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2024-30257?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | All versions | None |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.10.3 |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.10.3 |

Products: Fit2cloud 1panel.

## How do I fix CVE-2024-30257?

Upgrade github.com/1Panel-dev/1Panel to 1.10.3 or later.

## Is CVE-2024-30257 being exploited?

There is no known exploitation of CVE-2024-30257 in the wild and no public exploit code.

## Other vulnerabilities in 1Panel-dev 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30257 and fix it if it is affected.

What it is: CVE-2024-30257 is a low-severity vulnerability in 1Panel-dev 1Panel, published on 18 Apr 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-30257 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected all versions; no fix listed
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.10.3
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30257/ (Markdown: https://insights.sbomify.com/CVE-2024-30257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30257
- OSV: https://osv.dev/vulnerability/CVE-2024-30257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30257/
Summaries are generated and may contain mistakes; the official description above is the record.
