# CVE-2024-30262: Contao's remember-me tokens will not be cleared after a password change


- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-r4r6-j2j3-7pp5

## What is CVE-2024-30262?

CVE-2024-30262 is a medium-severity vulnerability in contao, published on 9 Apr 2024. 

### Official description

Contao is an open source content management system. Prior to version 4.13.40, when a frontend member changes their password in the personal data or the password lost module, the corresponding remember-me tokens are not removed. If someone compromises an account and is able to get a remember-me token, changing the password would not be enough to reclaim control over the account. Version 4.13.40 contains a fix for the issue. As a workaround, disable "Allow auto login" in the login module.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-384 (Session Fixation)

## Which versions are affected by CVE-2024-30262?

2 open source packages ship an affected version, including contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | All versions | 4.13.40 |
| `contao/core-bundle` | Packagist | All versions | 4.13.40 |

Products: Contao Contao.

## How do I fix CVE-2024-30262?

Upgrade contao/core-bundle to 4.13.40 or later.

## Is CVE-2024-30262 being exploited?

There is no known exploitation of CVE-2024-30262 in the wild and no public exploit code.

## Other vulnerabilities in contao

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-30262 and fix it if it is affected.

What it is: CVE-2024-30262 is a medium-severity vulnerability in contao, published on 9 Apr 2024. 
Exploitation: There is no known exploitation of CVE-2024-30262 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected all versions; fixed in 4.13.40
- contao/core-bundle (Packagist): affected all versions; fixed in 4.13.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-30262/ (Markdown: https://insights.sbomify.com/CVE-2024-30262/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-30262
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-30262
- OSV: https://osv.dev/vulnerability/CVE-2024-30262

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-30262/
Summaries are generated and may contain mistakes; the official description above is the record.
