CVE-2024-30266 Wasmtime vulnerable to panic when using a dropped extenref-typed element segment

Low 3.3 Published Updated

A malicious WebAssembly module can cause the Wasmtime runtime to panic, leading to a denial of service for the host application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2024-30266?

CVE-2024-30266 is a low-severity denial of service vulnerability in bytecodealliance wasmtime, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

wasmtime is a runtime for WebAssembly. The 19.0.0 release of Wasmtime contains a regression introduced during its development which can lead to a guest WebAssembly module causing a panic in the host runtime. A valid WebAssembly module, when executed at runtime, may cause this panic. This vulnerability has been patched in version 19.0.1.

Weakness: CWE-843

Which versions are affected by CVE-2024-30266?

4 open source packages ship an affected version, including wasmtime. It affects 1 product.

PackageAffectedFixed in
wasmtime PyPIAll versions to 19.0.0None
wasmtime crates.ioFrom 19.0.019.0.1
wasmtime crates.ioFrom 19.0.019.0.1
wasmtime crates.ioFrom 19.0.019.0.1

Products include Bytecodealliance Wasmtime.

How do I fix CVE-2024-30266?

Upgrade wasmtime to 19.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-30266 being exploited?

There is no known exploitation of CVE-2024-30266 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2024-30266, GHSA-75hq-h6g9-h4q5, PYSEC-2024-327, RUSTSEC-2024-0441, UBUNTU-CVE-2024-30266.

Is CVE-2024-30266 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free