CVE-2024-30453 WordPress Brave plugin <= 0.6.5 - Server Side Request Forgery (SSRF) vulnerability

Medium 5.4 Published Updated

An attacker can exploit a Server-Side Request Forgery vulnerability in the Brave Popup Builder plugin to make arbitrary requests from the server.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-30453?

CVE-2024-30453 is a medium-severity server-side request forgery vulnerability in Brave Popup Builder, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Server-Side Request Forgery (SSRF) vulnerability in Brave Brave Popup Builder.This issue affects Brave Popup Builder: from n/a through 0.6.5.

Weakness: CWE-918

Which versions are affected by CVE-2024-30453?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.

PackageAffectedFixed in
wordpress BitnamiAll versions0.6.6
wordpress-multisite BitnamiAll versions0.6.6

How do I fix CVE-2024-30453?

Upgrade wordpress to 0.6.6 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2024-30453 being exploited?

There is no known exploitation of CVE-2024-30453 in the wild and no public exploit code.

Sources

Also known as BIT-wordpress-2024-30453, BIT-wordpress-multisite-2024-30453, GHSA-fr96-wc8w-hg4c.

Is CVE-2024-30453 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free