{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2024-30453 in the wild and no public exploit code.","fix":"Upgrade wordpress to 0.6.6 or later.","what":"CVE-2024-30453 is a medium-severity server-side request forgery vulnerability in Brave Popup Builder, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-30453 and fix it if it is affected.\n\nWhat it is: CVE-2024-30453 is a medium-severity server-side request forgery vulnerability in Brave Popup Builder, published on 29 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-30453 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 0.6.6\n- wordpress-multisite (Bitnami): affected all versions; fixed in 0.6.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-30453/ (Markdown: https://insights.sbomify.com/CVE-2024-30453/index.md)","id":"CVE-2024-30453","markdown":"https://insights.sbomify.com/CVE-2024-30453/index.md","name":"CVE-2024-30453","record":{"aliases":["BIT-wordpress-2024-30453","BIT-wordpress-multisite-2024-30453","GHSA-fr96-wc8w-hg4c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the Brave Popup Builder plugin to make arbitrary requests from the server.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Server-Side Request Forgery (SSRF) vulnerability in Brave Brave Popup Builder.This issue affects Brave Popup Builder: from n/a through 0.6.5.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Brave plugin \u003c= 0.6.5 - Server Side Request Forgery (SSRF) vulnerability","id":"CVE-2024-30453","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"WordPress WP SMS plugin \u003c= 6.6.2 - Cross Site Request Forgery (CSRF) vulnerability","id":"CVE-2024-30454"},"packages":[{"ecosystem":"Bitnami","fixed":["0.6.6"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-30453"},{"ecosystem":"Bitnami","fixed":["0.6.6"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-30453"}],"prev":{"headline":"WordPress Landing Page Builder plugin \u003c= 1.5.1.7 - Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-30452"},"products":["Brave Popup Builder"],"published":"2024-03-29","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Brave"]},"summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in the Brave Popup Builder plugin to make arbitrary requests from the server.","url":"https://insights.sbomify.com/CVE-2024-30453/"}